アクセス解析
FORTI 's Footprint
FC2Blog | RSS1.0 | ログイン | 投稿 

FORTI 's Footprint

気になったニュース、動画、仕事や生活でのできごとをなんとなく書き記す・・・
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
--.--.--.-- --:-- | スポンサー広告 | trackback(-) | comment(-)
RHEL ES4のカーネルをあげる必要があり、RHNでパッケージをダウンロードしました。
で、いざカーネルインストールを行ったら、、、あれ?他のパッケージが必要?mkinitrdって何よ?といった感じです。バージョンの上がり方によっては、すんなり入るんで見落としがちです。

しかも、これ客先立ったんで、うんわーって感じでした。
結局別の理由でカーネルアップデートは無くなったんですが、依存するパッケージはきちんと確認するべきですね。

該当パッケージの依存関係は以下のコマンドで確認できます。

rpm -qR [パッケージ]

以下、カーネルの依存関係を実際に調べた結果です。

[root@ES4U3 ~]# rpm -qR kernel-2.6.9-34.0.2.EL
rpmlib(VersionedDependencies) <= 3.0.3-1
fileutils
module-init-tools
initscripts >= 5.83
mkinitrd >= 4.2.1.6-1
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

これからは、チェックを怠らないようにします・・・
スポンサーサイト
2006.07.21.Fri 14:08 | Linux | trackback(0) | comment(0)
<< 2017.11 >>
S M T W T F S
- - - 1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 - -
ENTRIES
CATEGORY
ARCHIVES
COMMENTS
TRACKBACKS
LINKS
PROFILE

FORTI
職業:見習いエンジニア
住処:東京都市部
好きな物:子供、映画、抹茶、
       スポーツ全般、お笑い
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。